summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2023-06-10 17:17:04 +0200
committerGitHub <noreply@github.com>2023-06-10 17:17:04 +0200
commit82f72f4f836251846492948aebd54a7536bc6da7 (patch)
treec2ae3eb8fb32efe038a4c29830552aa633517e3f /src/CMakeLists.txt
parentf24f0a793ce62c1cb91eb17a2d3a00763c2bac3a (diff)
parent0eb4524a793449338d696fa04fe377f91aa9c0cd (diff)
downloadfork-ledger-82f72f4f836251846492948aebd54a7536bc6da7.tar.gz
fork-ledger-82f72f4f836251846492948aebd54a7536bc6da7.tar.bz2
fork-ledger-82f72f4f836251846492948aebd54a7536bc6da7.zip
Merge pull request #2261 from afh/bsd-pic
cmake: Add -fPIC to compile flags
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f229d70c..f64ab839 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -287,6 +287,8 @@ if (BUILD_LIBRARY)
INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}"
VERSION ${Ledger_VERSION_MAJOR}
SOVERSION ${Ledger_VERSION_MAJOR})
+ set_source_files_properties(
+ ${LEDGER_CLI_SOURCES} PROPERTIES COMPILE_FLAGS "-fPIC")
add_executable(ledger main.cc global.cc)
target_link_libraries(ledger libledger)