summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorHenrik Pingel <knowhy@gmail.com>2020-05-08 10:46:44 +0200
committerMartin Michlmayr <tbm@cyrius.com>2020-05-13 08:26:39 +0800
commitb24de38c90da7890bd1bf258dec2058f4a66b5ef (patch)
tree5d3d5ab6cbc2a55fd700fcf47f1c1cd40c92a42c /src/CMakeLists.txt
parent6934ed807e13e990b897c832674b1e680d905d8f (diff)
downloadfork-ledger-b24de38c90da7890bd1bf258dec2058f4a66b5ef.tar.gz
fork-ledger-b24de38c90da7890bd1bf258dec2058f4a66b5ef.tar.bz2
fork-ledger-b24de38c90da7890bd1bf258dec2058f4a66b5ef.zip
Fix: library path issue
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 167f5515..b3d13a29 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -273,6 +273,7 @@ endif()
include(GNUInstallDirs)
if (BUILD_LIBRARY)
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
add_library(libledger SHARED ${LEDGER_SOURCES})
add_ledger_library_dependencies(libledger)
set_target_properties(libledger PROPERTIES