summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2014-02-03 12:02:03 +0100
committerAlexis Hildebrandt <afh@surryhill.net>2014-02-03 12:02:03 +0100
commitb359e851fee883f33ec85aeb2425ae0c2a7b2408 (patch)
tree93d6cba6ede3e486d7be060cbd97d628adbc18ea /src/CMakeLists.txt
parentdcb24fbb5c9b35b36b7e66da6b5cbce6ff150ed4 (diff)
downloadfork-ledger-b359e851fee883f33ec85aeb2425ae0c2a7b2408.tar.gz
fork-ledger-b359e851fee883f33ec85aeb2425ae0c2a7b2408.tar.bz2
fork-ledger-b359e851fee883f33ec85aeb2425ae0c2a7b2408.zip
Correctly set runtime path on Linux on install
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index b34e1c52..7bf7aad6 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -252,11 +252,11 @@ add_pch_rule(${PROJECT_BINARY_DIR}/system.hh LEDGER_SOURCES main.cc global.cc)
include(GNUInstallDirs)
if(BUILD_LIBRARY)
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
add_library(libledger SHARED ${LEDGER_SOURCES} ${PROJECT_SOURCE_DIR}/lib/sha1.cpp)
add_ledger_library_dependencies(libledger)
set_target_properties(libledger PROPERTIES
PREFIX ""
- #INSTALL_NAME_DIR "@executable_path/../lib"
INSTALL_NAME_DIR "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}"
VERSION ${Ledger_VERSION_MAJOR}
SOVERSION ${Ledger_VERSION_MAJOR})