summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Landscheidt <tim@tim-landscheidt.de>2019-01-27 14:09:31 +0000
committerTim Landscheidt <tim@tim-landscheidt.de>2019-01-30 00:10:52 +0000
commitb554d1296888f567c3a661cbd6de2a57457528d1 (patch)
tree9b4e421bf1b2b6c5c35bb11d1693ece418d605fc /src/CMakeLists.txt
parent0c0f696fd2ae0e3d801bb0b534f9f20bcacc86b2 (diff)
downloadfork-ledger-b554d1296888f567c3a661cbd6de2a57457528d1.tar.gz
fork-ledger-b554d1296888f567c3a661cbd6de2a57457528d1.tar.bz2
fork-ledger-b554d1296888f567c3a661cbd6de2a57457528d1.zip
Add Travis CI setup for macOS and homebrew-installed Boost
On macOS, CMake detects the Boost.Python component installed by homebrew only when named "python27". Thus this change not only adds a Travis CI setup for macOS, but also a CMake option to switch the component name between "python" and "python27". In addition, precompiling system.hh does not work with the current setup for Clang, so another CMake option to disable it is added. The currently used commands to compile specific versions of Boost do not produce a result that works out of the box on macOS. It should be possible just to mimic homebrew's formula for boost-python (https://github.com/Homebrew/homebrew-core/blob/master/Formula/boost-python.rb), but for the moment on macOS this change tests only against Boost installed by homebrew.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 06acecf2..9b39ea94 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -267,7 +267,9 @@ else()
endmacro(ADD_PCH_RULE _header_filename _src_list _other_srcs)
endif()
-add_pch_rule(${PROJECT_BINARY_DIR}/system.hh LEDGER_SOURCES LEDGER_CLI_SOURCES)
+if(PRECOMPILE_SYSTEM_HH)
+ add_pch_rule(${PROJECT_BINARY_DIR}/system.hh LEDGER_SOURCES LEDGER_CLI_SOURCES)
+endif()
include(GNUInstallDirs)