summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorKan-Ru Chen (陳侃如) <kanru@kanru.info>2014-02-13 18:40:06 +0800
committerKan-Ru Chen (陳侃如) <kanru@kanru.info>2014-02-13 18:40:06 +0800
commitd5b5ea02138107918642532a266550d1ab4122d3 (patch)
tree58ec47b437965f551416bfd3d125a542cd382d8e /src/CMakeLists.txt
parentc59aadaace0b142eacb89d40921ac331887bb671 (diff)
downloadfork-ledger-d5b5ea02138107918642532a266550d1ab4122d3.tar.gz
fork-ledger-d5b5ea02138107918642532a266550d1ab4122d3.tar.bz2
fork-ledger-d5b5ea02138107918642532a266550d1ab4122d3.zip
Correctly justify Unicode characters in terminal
Many Unicode characters take more spaces than one ASCII character. For example, Chinese characters are two characters wide when using monospace font in terminal. This patch use wcwidth of Markus Kuhn to count the correct width for justification.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 7bf7aad6..8359308e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -49,7 +49,8 @@ set(LEDGER_SOURCES
times.cc
error.cc
utils.cc
- strptime.cc)
+ strptime.cc
+ wcwidth.cc)
if(HAVE_BOOST_PYTHON)
list(APPEND LEDGER_SOURCES