summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2023-11-22 16:47:21 -0800
committerJohn Wiegley <johnw@newartisans.com>2024-08-05 08:35:56 -0700
commitdb0661dbb51e9082e47926c31e93bdc97b491bf9 (patch)
treee60f7dc32ebe9c24cb26eeb8c8438de7e891fe6b /src/CMakeLists.txt
parente6dae78c033ea970a459b1a0ccc2f1310d1bff96 (diff)
downloadfork-ledger-db0661dbb51e9082e47926c31e93bdc97b491bf9.tar.gz
fork-ledger-db0661dbb51e9082e47926c31e93bdc97b491bf9.tar.bz2
fork-ledger-db0661dbb51e9082e47926c31e93bdc97b491bf9.zip
Add support for hash chaining to detect modifications in postings
The following details of a posting contribute to its hash: fullname of account string representation of amount Each posting hashes contributes to the transaction hash, which is compromised of: previous transaction’s hash (as encountered in parsing order) actual date optional auxiliary date optional code payee hashes of all postings Note that this means that changes in the “code” or any of the comments
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 0d6bc085..d996a5a1 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -51,7 +51,8 @@ set(LEDGER_SOURCES
times.cc
error.cc
utils.cc
- wcwidth.cc)
+ wcwidth.cc
+ sha512.cc)
if (HAVE_GPGME)
list(APPEND LEDGER_SOURCES