summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2015-01-12 11:15:03 +0100
committerAlexis Hildebrandt <afh@surryhill.net>2015-01-15 14:53:16 +0100
commit01252035cdc23ff64a593471e0272e7bbe9b1786 (patch)
tree2076af66e543401ef56630b9bb178d532926f4f7 /test/CMakeLists.txt
parentd5c1e05a59c7c1ec4654710377920a51327b9c17 (diff)
downloadfork-ledger-01252035cdc23ff64a593471e0272e7bbe9b1786.tar.gz
fork-ledger-01252035cdc23ff64a593471e0272e7bbe9b1786.tar.bz2
fork-ledger-01252035cdc23ff64a593471e0272e7bbe9b1786.zip
[doc] Add CheckTests to ctest
to check whether all available ledger options documented and are being tested. Signed-off-by: Alexis Hildebrandt <afh@surryhill.net>
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 44db81fb..37224d40 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -42,10 +42,15 @@ if (PYTHONINTERP_FOUND)
foreach(TestFile ${${_class}_TESTS})
get_filename_component(TestFile_Name ${TestFile} NAME_WE)
add_test(NAME ${_class}Test_${TestFile_Name}
- COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/DocTests.py
+ COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/${_class}.py
--ledger $<TARGET_FILE:ledger> --file ${TestFile})
set_target_properties(check PROPERTIES DEPENDS ${_class}Test_${TestFile_Name})
endforeach()
+
+ set(_class CheckTests)
+ add_test(NAME ${_class}
+ COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/${_class}.py
+ --ledger $<TARGET_FILE:ledger> --source ${PROJECT_SOURCE_DIR})
endif()
### CMakeLists.txt ends here