summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Wiegley <johnw@newartisans.com>2012-05-19 19:32:40 -0500
committerJohn Wiegley <johnw@newartisans.com>2012-05-20 04:48:05 -0500
commit4681e58d7f3cda2a2ac6d05b6ec1a106f568e029 (patch)
tree488d6531d688c68713baa5c1d70fb37be198b861 /test/CMakeLists.txt
parent303976e563608d8a1f4eb09ac5c9402ae5ce74fd (diff)
downloadfork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.tar.gz
fork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.tar.bz2
fork-ledger-4681e58d7f3cda2a2ac6d05b6ec1a106f568e029.zip
Converted the Ledger build system to use CMake
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 00000000..92c2a763
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,16 @@
+include(ProcessorCount)
+ProcessorCount(PROCESSORS)
+
+if(NOT PROCESSORS EQUAL 0)
+ set(CTEST_BUILD_FLAGS -j${PROCESSORS})
+ set(ctest_test_args ${ctest_test_args} PARALLEL_LEVEL ${PROCESSORS})
+endif()
+
+get_target_property(LEDGER_LOCATION ledger LOCATION)
+
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
+
+add_subdirectory(unit)
+add_subdirectory(regress)
+
+### CMakeLists.txt ends here