summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorTim Landscheidt <tim@tim-landscheidt.de>2019-01-22 15:23:44 +0000
committerTim Landscheidt <tim@tim-landscheidt.de>2019-01-22 15:38:40 +0000
commit52439c2d762f34f4823f0c1178131dc8ad8b03c4 (patch)
tree9ea6039f545014763fbe152aca285e27f8fd85e0 /test/CMakeLists.txt
parent53f4035a2f4a6f33b447ce3658c4dc062058c422 (diff)
downloadfork-ledger-52439c2d762f34f4823f0c1178131dc8ad8b03c4.tar.gz
fork-ledger-52439c2d762f34f4823f0c1178131dc8ad8b03c4.tar.bz2
fork-ledger-52439c2d762f34f4823f0c1178131dc8ad8b03c4.zip
Do not set dependencies for target check
The set_target_properties() commands themselves do not cause the tests to run if the target check is made, and as the target check executes ctest, all tests will be run anyway.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 0 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index d0b62f6e..41eecb36 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -27,8 +27,6 @@ macro(add_ledger_harness_tests _class)
${TestFile} ${TEST_PYTHON_FLAGS})
set_tests_properties(${_class}Test_${TestFile_Name}
PROPERTIES ENVIRONMENT "TZ=${Ledger_TEST_TIMEZONE}")
- set_target_properties(check
- PROPERTIES DEPENDS ${_class}Test_${TestFile_Name})
endif()
endforeach()
endif()
@@ -48,8 +46,6 @@ if (PYTHONINTERP_FOUND)
--ledger $<TARGET_FILE:ledger> --file ${TestFile})
set_tests_properties(${_class}Test_${TestFile_Name}
PROPERTIES ENVIRONMENT "TZ=${Ledger_TEST_TIMEZONE}")
- set_target_properties(check
- PROPERTIES DEPENDS ${_class}Test_${TestFile_Name})
endforeach()
# CheckManpage and CheckTexinfo are disabled, since they do not work