summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2015-07-28 23:01:48 +0200
committerAlexis Hildebrandt <afh@surryhill.net>2015-07-28 23:28:41 +0200
commitc4db52614e75e1c564ab4591e1dc5240d33a2293 (patch)
tree32304596923bb29d481a33bdb6383d31fcef1492 /test/CMakeLists.txt
parent69fa2fc671e7a02d416270d1d68df71a0f096714 (diff)
downloadfork-ledger-c4db52614e75e1c564ab4591e1dc5240d33a2293.tar.gz
fork-ledger-c4db52614e75e1c564ab4591e1dc5240d33a2293.tar.bz2
fork-ledger-c4db52614e75e1c564ab4591e1dc5240d33a2293.zip
[travis] Run documentation checks as reports
which are allowed to fail instead of strict tests.
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6eb9f956..0e7d5f2c 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -47,7 +47,9 @@ if (PYTHONINTERP_FOUND)
set_target_properties(check PROPERTIES DEPENDS ${_class}Test_${TestFile_Name})
endforeach()
- list(APPEND CheckOptions CheckManpage CheckTexinfo CheckBaselineTests)
+ # CheckManpage and CheckTexinfo are disabled, since they do not work
+ # reliably yet, instead they are being run as a Travis CI report.
+ list(APPEND CheckOptions CheckBaselineTests) #CheckManpage CheckTexinfo
foreach(_class ${CheckOptions})
add_test(NAME ${_class}
COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/${_class}.py