summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2015-01-21 06:50:56 +0100
committerAlexis Hildebrandt <afh@surryhill.net>2015-01-21 08:03:53 +0100
commitc7a30bf7d8e2b79624925a6f27281a0297217398 (patch)
tree74b0a446d98ffaa4b49ea6c500d73552d73f54b2 /test/CMakeLists.txt
parent213f0341c1559bad2e873c309247b4de8acfa746 (diff)
downloadfork-ledger-c7a30bf7d8e2b79624925a6f27281a0297217398.tar.gz
fork-ledger-c7a30bf7d8e2b79624925a6f27281a0297217398.tar.bz2
fork-ledger-c7a30bf7d8e2b79624925a6f27281a0297217398.zip
[tests] Refactor CheckTests.py into custom scripts
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 37224d40..6eb9f956 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -47,10 +47,12 @@ if (PYTHONINTERP_FOUND)
set_target_properties(check PROPERTIES DEPENDS ${_class}Test_${TestFile_Name})
endforeach()
- set(_class CheckTests)
- add_test(NAME ${_class}
- COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/${_class}.py
- --ledger $<TARGET_FILE:ledger> --source ${PROJECT_SOURCE_DIR})
+ list(APPEND CheckOptions CheckManpage CheckTexinfo CheckBaselineTests)
+ foreach(_class ${CheckOptions})
+ add_test(NAME ${_class}
+ COMMAND ${PYTHON_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/${_class}.py
+ --ledger $<TARGET_FILE:ledger> --source ${PROJECT_SOURCE_DIR})
+ endforeach()
endif()
### CMakeLists.txt ends here