summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexis Hildebrandt <afh@surryhill.net>2023-12-05 23:27:55 +0100
committerAlexis Hildebrandt <afh@surryhill.net>2023-12-05 23:27:55 +0100
commitecbfaa9c2e6733d516351d0a815b4cd822bfed39 (patch)
tree83af279c13a4a6d1032650aca4f7a2b21b49ad3e /test/CMakeLists.txt
parent2c0cf2e0c933b16a107cc29451ad92d3a48bb481 (diff)
parent1ab0add0afbd91624133141158349c3551c42a93 (diff)
downloadfork-ledger-ecbfaa9c2e6733d516351d0a815b4cd822bfed39.tar.gz
fork-ledger-ecbfaa9c2e6733d516351d0a815b4cd822bfed39.tar.bz2
fork-ledger-ecbfaa9c2e6733d516351d0a815b4cd822bfed39.zip
Merge branch 'master' into modernize-test-scripts
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt10
1 files changed, 1 insertions, 9 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 559c757a..25d91a9e 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -19,15 +19,7 @@ macro(add_ledger_harness_tests _class)
file(GLOB ${_class}_TESTS *.test)
foreach(TestFile ${${_class}_TESTS})
get_filename_component(TestFile_Name ${TestFile} NAME_WE)
- string(FIND ${TestFile_Name} "_py" TestFile_IsPythonTest)
- if ((TestFile_IsPythonTest GREATER -1))
- get_filename_component(TestFile_FullName ${TestFile} NAME)
- string(FIND ${TestFile_FullName} "_py.test" TestFile_IsAnyPythonTest)
- string(FIND ${TestFile_FullName} "_py${Python_VERSION_MAJOR}.test" TestFile_IsThisPythonTest)
- if ((TestFile_IsAnyPythonTest EQUAL -1) AND (TestFile_IsThisPythonTest EQUAL -1))
- continue()
- endif()
- endif()
+ string(FIND ${TestFile_Name} "_py.test" TestFile_IsPythonTest)
if ((TestFile_IsPythonTest EQUAL -1) OR HAVE_BOOST_PYTHON)
add_test(NAME ${_class}Test_${TestFile_Name}
COMMAND ${Python_EXECUTABLE} ${PROJECT_SOURCE_DIR}/test/RegressTests.py