summaryrefslogtreecommitdiff
path: root/test/unit/CMakeLists.txt
diff options
context:
space:
mode:
authorJohann Klähn <kljohann@gmail.com>2013-10-23 23:08:18 +0200
committerJohann Klähn <kljohann@gmail.com>2014-02-01 01:30:53 +0100
commit89c21e9967cec214597044aa582741470404977c (patch)
treef54c388e606e5f9296f991cae64678bdbaf0a8b2 /test/unit/CMakeLists.txt
parent35c1bf03eca615ee747162c356c74ba280a6d03c (diff)
downloadfork-ledger-89c21e9967cec214597044aa582741470404977c.tar.gz
fork-ledger-89c21e9967cec214597044aa582741470404977c.tar.bz2
fork-ledger-89c21e9967cec214597044aa582741470404977c.zip
build shared library/python module, clean up CMake
libledger will now be built as a shared library. You can 'import ledger' from python IFF you copy libledger.so to ledger.so or create a symlink.
Diffstat (limited to 'test/unit/CMakeLists.txt')
-rw-r--r--test/unit/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/test/unit/CMakeLists.txt b/test/unit/CMakeLists.txt
index 5ecd5a87..b3639c06 100644
--- a/test/unit/CMakeLists.txt
+++ b/test/unit/CMakeLists.txt
@@ -1,5 +1,5 @@
macro(add_ledger_test _name)
- add_ledger_library_dependencies(${_name})
+ target_link_libraries(${_name} libledger)
add_test(Ledger${_name} ${PROJECT_BINARY_DIR}/${_name})
endmacro(add_ledger_test _name)