summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d302761a..9f7e4ca5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -83,7 +83,13 @@ endif()
# Set BOOST_ROOT to help CMake to find the right Boost version
find_package(Boost 1.49.0
REQUIRED date_time filesystem system iostreams regex unit_test_framework
- ${BOOST_PYTHON})
+ ${BOOST_PYTHON} OPTIONAL_COMPONENTS nowide)
+
+# enable Boost::nowide library (for UTF8 command line args on Windows)
+set(HAVE_BOOST_NOWIDE 0)
+if (Boost_NOWIDE_FOUND)
+ set(HAVE_BOOST_NOWIDE 1)
+endif()
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
link_directories(${Boost_LIBRARY_DIRS})