summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 13962647..f18df69a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 2.8.5)
-project(Ledger)
+PROJECT(ledger)
set(Ledger_VERSION_MAJOR 3)
set(Ledger_VERSION_MINOR 0)
@@ -18,7 +18,8 @@ option(DISABLE_ASSERTS "Build without any internal consistency checks" OFF)
option(BUILD_DEBUG "Build support for runtime debugging" OFF)
option(BUILD_LIBRARY "Build and install Ledger as a library" ON)
-option(BUILD_DOCS "Build and install documentation" OFF)
+option(BUILD_DOCS "Build and install documentation" ON)
+option(BUILD_WEB_DOCS "Build version of documentation suitable for viewing online" OFF)
option(BUILD_EMACSLISP "Build and install ledger-mode for Emacs" OFF)
if(BUILD_DEBUG)
@@ -45,6 +46,7 @@ endif()
find_package(PythonInterp) # Used for running tests
if(USE_PYTHON)
+ set(Python_ADDITIONAL_VERSIONS 2.7 2.6)
find_package(PythonLibs)
if(PYTHONLIBS_FOUND)
set(BOOST_PYTHON python)
@@ -58,11 +60,13 @@ else()
set(HAVE_BOOST_PYTHON 0)
endif()
+# Set BOOST_ROOT to help CMake to find the right Boost version
find_package(Boost 1.46.0
REQUIRED date_time filesystem system iostreams regex unit_test_framework
${BOOST_PYTHON})
include_directories(SYSTEM ${Boost_INCLUDE_DIRS})
+link_directories(${Boost_LIBRARY_DIRS})
########################################################################
@@ -272,9 +276,7 @@ elseif(CMAKE_CXX_COMPILER MATCHES "g\\+\\+")
endif()
add_subdirectory(src)
-if(BUILD_DOCS)
- add_subdirectory(doc)
-endif()
+add_subdirectory(doc)
if(BUILD_EMACSLISP)
add_subdirectory(lisp)
endif()