summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bdf5b5d6..8a50450c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -18,6 +18,7 @@ libledger_la_CXXFLAGS =
libledger_la_SOURCES = \
binary.cc \
config.cc \
+ csv.cc \
derive.cc \
emacs.cc \
format.cc \
@@ -63,6 +64,7 @@ pkginclude_HEADERS = \
\
binary.h \
config.h \
+ csv.h \
derive.h \
emacs.h \
error.h \
@@ -151,11 +153,11 @@ endif
alltests.cc: $(TESTSUITES)
test -f $(TESTGEN) && python $(TESTGEN) -o $@ --error-printer $(TESTSUITES)
-alltests: alltests.cc
+alltests: alltests.cc ledger
$(CXXCOMPILE) -I$(CXXTEST_DIR) -lexpat -lgmp -lpcre -o $@ \
alltests.cc -L. -L.libs -lamounts -lledger
-runtests: alltests ledger
+runtests: alltests
./alltests && tests/regress && tests/regtest
verify: runtests