summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 11 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index bf6e6836..c6f7fd33 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,19 @@
noinst_LIBRARIES = libledger.a
-libledger_a_CXXFLAGS = -DDEBUG_LEVEL=4 -DDO_CLEANUP
libledger_a_SOURCES = account.cc amount.cc autoxact.cc balance.cc binary.cc \
- config.cc datetime.cc debug.cc format.cc ledger.cc option.cc \
- parser.cc qif.cc quotes.cc textual.cc valexpr.cc value.cc walk.cc
+ config.cc datetime.cc format.cc ledger.cc option.cc parser.cc qif.cc \
+ quotes.cc textual.cc valexpr.cc value.cc walk.cc
+if DEBUG
+libledger_a_CXXFLAGS = -DDEBUG_LEVEL=4
+libledger_a_SOURCES += debug.cc
+endif
+if READ_GNUCASH
+libledger_a_SOURCES += gnucash.cc
+endif
bin_PROGRAMS = ledger
+if DEBUG
ledger_CXXFLAGS = -DDEBUG_LEVEL=4 -DDO_CLEANUP
+endif
ledger_SOURCES = main.cc
ledger_LDADD = $(LIBOBJS) libledger.a