summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am68
1 files changed, 32 insertions, 36 deletions
diff --git a/Makefile.am b/Makefile.am
index 5b147963..9f64ca1e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -12,65 +12,64 @@ lib_cppflags = -I$(srcdir)/src -I$(srcdir)/lib \
-I$(srcdir)/lib/utfcpp/source
libledger_util_la_SOURCES = \
- src/utils.cc \
- src/error.cc \
- src/times.cc \
- src/mask.cc \
src/stream.cc \
+ src/mask.cc \
+ src/times.cc \
+ src/error.cc \
+ src/utils.cc \
lib/sha1.cpp
libledger_util_la_CPPFLAGS = $(lib_cppflags)
libledger_util_la_LDFLAGS = -release $(VERSION).0
libledger_math_la_SOURCES = \
- src/amount.cc \
- src/commodity.cc \
- src/balance.cc \
+ src/value.cc \
src/balpair.cc \
- src/value.cc
+ src/balance.cc \
+ src/commodity.cc \
+ src/amount.cc
libledger_math_la_CPPFLAGS = $(lib_cppflags)
libledger_math_la_LDFLAGS = -release $(VERSION).0
libledger_expr_la_SOURCES = \
- src/token.cc \
- src/parser.cc \
- src/op.cc \
- src/expr.cc \
- src/scope.cc \
- src/predicate.cc \
+ src/option.cc \
src/format.cc \
- src/option.cc
+ src/predicate.cc \
+ src/scope.cc \
+ src/expr.cc \
+ src/op.cc \
+ src/parser.cc \
+ src/token.cc
libledger_expr_la_CPPFLAGS = $(lib_cppflags)
libledger_expr_la_LDFLAGS = -release $(VERSION).0
libledger_data_la_SOURCES = \
- src/item.cc \
- src/xact.cc \
- src/entry.cc \
- src/account.cc \
- src/journal.cc \
- src/textual.cc \
- src/timelog.cc \
+ src/compare.cc \
src/iterators.cc \
- src/compare.cc
+ src/timelog.cc \
+ src/textual.cc \
+ src/journal.cc \
+ src/account.cc \
+ src/entry.cc \
+ src/xact.cc \
+ src/item.cc
libledger_data_la_CPPFLAGS = $(lib_cppflags)
libledger_data_la_LDFLAGS = -release $(VERSION).0
libledger_report_la_SOURCES = \
- src/session.cc \
- src/report.cc \
- src/filters.cc \
- src/chain.cc \
- src/precmd.cc \
- src/output.cc \
- src/csv.cc \
- src/emacs.cc \
- src/help.cc \
+ src/quotes.cc \
src/derive.cc \
- src/quotes.cc
+ src/help.cc \
+ src/emacs.cc \
+ src/output.cc \
+ src/precmd.cc \
+ src/chain.cc \
+ src/filters.cc \
+ src/report.cc \
+ src/session.cc
libledger_report_la_CPPFLAGS = $(lib_cppflags)
libledger_report_la_LDFLAGS = -release $(VERSION).0
@@ -114,12 +113,10 @@ pkginclude_HEADERS = \
\
src/session.h \
src/report.h \
- src/handler.h \
src/filters.h \
src/chain.h \
src/precmd.h \
src/output.h \
- src/csv.h \
src/emacs.h \
src/help.h \
\
@@ -203,7 +200,6 @@ libledger_python_la_SOURCES = \
python/py_chain.cc \
python/py_commodity.cc \
python/py_compare.cc \
- python/py_csv.cc \
python/py_emacs.cc \
python/py_entry.cc \
python/py_expr.cc \