summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d2430126..4f3492b6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,7 +27,7 @@ AC_CHECK_LIB([xmlparse], [XML_ParserCreate],
# Check for options
AC_ARG_ENABLE(debug,
- [ --enable-debug Turn on debugging],
+ [ --enable-debug Turn on debugging],
[case "${enableval}" in
yes) debug=true ;;
no) debug=false ;;
@@ -35,6 +35,15 @@ AC_ARG_ENABLE(debug,
esac],[debug=false])
AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+AC_ARG_ENABLE(standalone,
+ [ --enable-standalone Build standalone on OS/X (see README)],
+ [case "${enableval}" in
+ yes) standalone=true ;;
+ no) standalone=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-standalone) ;;
+ esac],[standalone=false])
+AM_CONDITIONAL(STANDALONE, test x$standalone = xtrue)
+
# Checks for header files.
AC_STDC_HEADERS
AC_HAVE_HEADERS(sys/stat.h)