summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 0aae061b..51fcec85 100644
--- a/configure.in
+++ b/configure.in
@@ -2,8 +2,8 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.59)
-AC_INIT(ledger, 2.6, johnw@newartisans.com)
-AM_INIT_AUTOMAKE(ledger, 2.6)
+AC_INIT(ledger, 3.0, johnw@newartisans.com)
+AM_INIT_AUTOMAKE(ledger, 3.0)
AC_CONFIG_SRCDIR([main.cc])
AC_CONFIG_HEADER([acconf.h])
@@ -252,6 +252,16 @@ else
AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
fi
+# check for Precompiled headers (gcc4-style)
+AC_ARG_ENABLE(pch,
+ [ --enable-pch Enable support for pre-compiled headers],
+ [case "${enableval}" in
+ yes) pch=true ;;
+ no) pch=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-pch) ;;
+ esac],[pch=false])
+AM_CONDITIONAL(USE_PCH, test x$pch = xtrue)
+
# Check for options
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on debugging],
@@ -274,7 +284,7 @@ AC_STRUCT_TM
# Checks for library functions.
#AC_FUNC_ERROR_AT_LINE
AC_HEADER_STDC
-AC_CHECK_FUNCS([access mktime realpath stat strftime strptime getpwuid getpwnam])
+AC_CHECK_FUNCS([access mktime realpath strftime strptime getpwuid getpwnam])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT