summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 0 insertions, 40 deletions
diff --git a/configure.in b/configure.in
index 0059e0ea..49b3e773 100644
--- a/configure.in
+++ b/configure.in
@@ -187,46 +187,6 @@ else
AM_CONDITIONAL(HAVE_LIBOFX, false)
fi
-# check for Python
-AC_ARG_ENABLE(python,
- [ --enable-python Turn on Python support],
- [case "${enableval}" in
- yes) python=true ;;
- no) python=false ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-python) ;;
- esac],[python=false])
-AM_CONDITIONAL(USE_PYTHON, test x$python = xtrue)
-
-if [test x$python = xtrue ]; then
- AM_PATH_PYTHON(2.2,, :)
- if [test "$PYTHON" != :]; then
- AC_CACHE_CHECK(
- [if boost_python is available],
- [boost_python_cpplib_avail],
- [boost_python_save_libs=$LIBS
- LIBS="-lboost_python -lpython$PYTHON_VERSION $LIBS"
- AC_LANG_PUSH(C++)
- AC_TRY_LINK(
- [#include <boost/python.hpp>
- using namespace boost::python;
- class foo {};
- BOOST_PYTHON_MODULE(samp) {
- class_< foo > ("foo") ;
- }],
- [return 0],
- [boost_python_cpplib_avail=true],
- [boost_python_cpplib_avail=false])
- AC_LANG_POP
- LIBS=$boost_python_save_libs])
- AM_CONDITIONAL(HAVE_BOOST_PYTHON,
- test x$boost_python_cpplib_avail = xtrue)
- else
- AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
- fi
-else
- AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
-fi
-
# Check for options
AC_ARG_ENABLE(debug,
[ --enable-debug Turn on debugging],