summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in96
1 files changed, 96 insertions, 0 deletions
diff --git a/configure.in b/configure.in
new file mode 100644
index 00000000..4d568016
--- /dev/null
+++ b/configure.in
@@ -0,0 +1,96 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(ledger, 2.0, johnw@newartisans.com)
+AM_INIT_AUTOMAKE(ledger, 2.0)
+AC_CONFIG_SRCDIR([main.cc])
+AC_CONFIG_HEADER([acconf.h])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_MAKE_SET
+AC_PROG_RANLIB
+
+# Checks for libraries.
+AC_CHECK_LIB([gmp], [__gmpz_add], [],
+ AC_MSG_FAILURE("Could not find gmp (GNU multi-precision) library"))
+AC_CHECK_LIB([pcre], [pcre_compile], [],
+ AC_MSG_FAILURE("Could not find pcre (Perl regular expression) library"))
+AC_CHECK_LIB([xmlparse], [XML_ParserCreate],
+ [AC_DEFINE([HAVE_XMLPARSE], [1], [Support reading Gnucash and XML files])
+ AM_CONDITIONAL(HAVE_XMLPARSE, true)
+ AC_SUBST(LIBS, "-lxmlparse -lxmltok $LIBS")],
+ [AC_MSG_NOTICE([Could not find xmlparse library: Gnucash and XML support disabled])
+ AM_CONDITIONAL(HAVE_XMLPARSE, false)],
+ [-lxmltok])
+
+AC_ARG_ENABLE(python,
+ [ --enable-python Turn on Python support],
+ [case "${enableval}" in
+ yes) python=true ;;
+ no) python=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-python) ;;
+ esac],[python=false])
+AM_CONDITIONAL(USE_PYTHON, test x$python = xtrue)
+
+if [test x$python = xtrue ]; then
+ AM_PATH_PYTHON(2.2,, :)
+ if [test "$PYTHON" != :]; then
+ AC_CACHE_CHECK(
+ [if boost_python is available],
+ [boost_python_cpplib_avail],
+ [boost_python_save_libs=$LIBS
+ LIBS="-lboost_python $LIBS"
+ AC_LANG_PUSH(C++)
+ AC_TRY_COMPILE(
+ [#include <boost/python.hpp>
+ using namespace boost::python;
+ class foo {};
+ BOOST_PYTHON_MODULE(samp) {
+ class_< foo > ("foo") ;
+ }],
+ [return 0],
+ [boost_python_cpplib_avail=true],
+ [boost_python_cpplib_avail=false])
+ AC_LANG_POP
+ LIBS=$boost_python_save_libs])
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON,
+ test x$boost_python_cpplib_avail = xtrue)
+ else
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
+ fi
+else
+ AM_CONDITIONAL(HAVE_BOOST_PYTHON, false)
+fi
+
+# Check for options
+AC_ARG_ENABLE(debug,
+ [ --enable-debug Turn on debugging],
+ [case "${enableval}" in
+ yes) debug=true ;;
+ no) debug=false ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-debug) ;;
+ esac],[debug=false])
+AM_CONDITIONAL(DEBUG, test x$debug = xtrue)
+
+# Checks for header files.
+AC_STDC_HEADERS
+AC_HAVE_HEADERS(sys/stat.h)
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_TYPE_SIZE_T
+AC_STRUCT_TM
+
+# Checks for library functions.
+#AC_FUNC_ERROR_AT_LINE
+AC_HEADER_STDC
+#AC_FUNC_MALLOC
+#AC_FUNC_MKTIME
+#AC_FUNC_STAT
+#AC_FUNC_STRFTIME
+AC_CHECK_FUNCS([memset strchr strstr access mktime stat strftime strptime])
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT