summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix23
1 files changed, 16 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 7a822bbe..f1745ce4 100644
--- a/default.nix
+++ b/default.nix
@@ -1,17 +1,26 @@
-{ stdenv, fetchgit, cmake, ninja, boost, gmp, mpfr, libedit, python, texinfo }:
+{ stdenv, fetchgit, cmake, boost, gmp, mpfr, libedit, python
+, texinfo, gnused }:
+
+let
+ rev = "20140417";
+in
stdenv.mkDerivation {
- name = "ledger-3.0.2";
- version = "3.0.2";
+ name = "ledger-3.0.2.${rev}";
src = ./.;
- buildInputs = [ cmake ninja boost gmp mpfr libedit python texinfo ];
+ buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];
- # Tests on Darwin are failing
- doCheck = !stdenv.isDarwin;
enableParallelBuilding = true;
+ # Skip byte-compiling of emacs-lisp files because this is currently
+ # broken in ledger...
+ postInstall = ''
+ mkdir -p $out/share/emacs/site-lisp/
+ cp -v $src/lisp/*.el $out/share/emacs/site-lisp/
+ '';
+
meta = {
homepage = "http://ledger-cli.org/";
description = "A double-entry accounting system with a command-line reporting interface";
@@ -25,6 +34,6 @@ stdenv.mkDerivation {
'';
platforms = stdenv.lib.platforms.all;
- maintainers = with stdenv.lib.maintainers; [ simons the-kenny ];
+ maintainers = with stdenv.lib.maintainers; [ simons the-kenny jwiegley ];
};
}