summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..c9f14f69
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchgit, cmake, boost, gmp, mpfr, libedit, python, texinfo }:
+
+stdenv.mkDerivation {
+ name = "ledger-3.0.1";
+ version = "3.0.1";
+
+ src = ./.;
+
+ buildInputs = [ cmake boost gmp mpfr libedit python texinfo ];
+
+ # Tests on Darwin are failing
+ doCheck = !stdenv.isDarwin;
+ enableParallelBuilding = true;
+
+ meta = {
+ homepage = "http://ledger-cli.org/";
+ description = "A double-entry accounting system with a command-line reporting interface";
+ license = "BSD";
+
+ longDescription = ''
+ Ledger is a powerful, double-entry accounting system that is accessed
+ from the UNIX command-line. This may put off some users, as there is
+ no flashy UI, but for those who want unparalleled reporting access to
+ their data, there really is no alternative.
+ '';
+
+ platforms = stdenv.lib.platforms.all;
+ maintainers = with stdenv.lib.maintainers; [ simons the-kenny ];
+ };
+}