summaryrefslogtreecommitdiff
path: root/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 00000000..f1745ce4
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchgit, cmake, boost, gmp, mpfr, libedit, python
+, texinfo, gnused }:
+
+let
+ rev = "20140417";
+in
+
+stdenv.mkDerivation {
+ name = "ledger-3.0.2.${rev}";
+
+ src = ./.;
+
+ buildInputs = [ cmake boost gmp mpfr libedit python texinfo gnused ];
+
+ enableParallelBuilding = true;
+
+ # Skip byte-compiling of emacs-lisp files because this is currently
+ # broken in ledger...
+ postInstall = ''
+ mkdir -p $out/share/emacs/site-lisp/
+ cp -v $src/lisp/*.el $out/share/emacs/site-lisp/
+ '';
+
+ meta = {
+ homepage = "http://ledger-cli.org/";
+ description = "A double-entry accounting system with a command-line reporting interface";
+ license = "BSD";
+
+ longDescription = ''
+ Ledger is a powerful, double-entry accounting system that is accessed
+ from the UNIX command-line. This may put off some users, as there is
+ no flashy UI, but for those who want unparalleled reporting access to
+ their data, there really is no alternative.
+ '';
+
+ platforms = stdenv.lib.platforms.all;
+ maintainers = with stdenv.lib.maintainers; [ simons the-kenny jwiegley ];
+ };
+}