summaryrefslogtreecommitdiff
path: root/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'doc/CMakeLists.txt')
-rw-r--r--doc/CMakeLists.txt15
1 files changed, 8 insertions, 7 deletions
diff --git a/doc/CMakeLists.txt b/doc/CMakeLists.txt
index 275678a8..2777da68 100644
--- a/doc/CMakeLists.txt
+++ b/doc/CMakeLists.txt
@@ -96,10 +96,11 @@ if(CMAKE_INSTALL_MANDIR)
DESTINATION ${CMAKE_INSTALL_MANDIR}/man1 COMPONENT doc)
endif(CMAKE_INSTALL_MANDIR)
-if(CMAKE_INSTALL_DOCDIR)
- foreach(file ${info_files})
- get_filename_component(file_base ${file} NAME_WE)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${file_base}.pdf
- DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT doc OPTIONAL)
- endforeach()
-endif(CMAKE_INSTALL_DOCDIR)
+foreach(file ${info_files})
+ get_filename_component(file_base ${file} NAME_WE)
+
+ install(FILES ${CMAKE_CURRENT_SOURCE_DIR}/${file}
+ DESTINATION ${CMAKE_INSTALL_INFODIR} COMPONENT doc)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${file_base}.pdf
+ DESTINATION ${CMAKE_INSTALL_DOCDIR} COMPONENT doc OPTIONAL)
+endforeach()