summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'python/setup.py')
-rwxr-xr-xpython/setup.py19
1 files changed, 19 insertions, 0 deletions
diff --git a/python/setup.py b/python/setup.py
new file mode 100755
index 00000000..4413a88d
--- /dev/null
+++ b/python/setup.py
@@ -0,0 +1,19 @@
+#!/usr/bin/env python
+
+from distutils.core import setup, Extension
+
+import os
+
+defines = [('PYTHON_MODULE', 1)]
+libs = os.environ["PYLIBS"].split()
+
+setup(name = "Ledger",
+ version = "2.7",
+ description = "Ledger Accounting Library",
+ author = "John Wiegley",
+ author_email = "johnw@newartisans.com",
+ url = "http://www.newartisans.com/software/ledger.html",
+ ext_modules = [
+ Extension("ledger",
+ [os.path.join(os.environ['SRCDIR'], "pyledger.cc")],
+ define_macros = defines, libraries = libs)])