summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py22
1 files changed, 0 insertions, 22 deletions
diff --git a/setup.py b/setup.py
deleted file mode 100755
index 874c8cca..00000000
--- a/setup.py
+++ /dev/null
@@ -1,22 +0,0 @@
-#!/usr/bin/env python
-
-from distutils.core import setup, Extension
-
-import os
-
-libs = ["ledger", "boost_python", "gmp", "pcre"]
-
-if os.environ.has_key ("READ_GNUCASH") and\
- os.environ["READ_GNUCASH"] == "true":
- libs.extend (["xmlparse", "xmltok"])
-
-setup(name = "Ledger",
- version = "2.0b",
- description = "Ledger Accounting Tool",
- author = "John Wiegley",
- author_email = "johnw@newartisans.com",
- url = "http://www.newartisans.com/johnw/",
- ext_modules = [
- Extension("ledger", ["pyledger.cc"],
- define_macros = [('PYTHON_MODULE', 1)],
- libraries = libs)])