summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 7 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index e18031b1..874c8cca 100755
--- a/setup.py
+++ b/setup.py
@@ -2,7 +2,13 @@
from distutils.core import setup, Extension
-libs = ["ledger", "boost_python", "gmp", "pcre", "xmlparse", "xmltok"]
+import os
+
+libs = ["ledger", "boost_python", "gmp", "pcre"]
+
+if os.environ.has_key ("READ_GNUCASH") and\
+ os.environ["READ_GNUCASH"] == "true":
+ libs.extend (["xmlparse", "xmltok"])
setup(name = "Ledger",
version = "2.0b",