summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
new file mode 100644
index 00000000..92c2a763
--- /dev/null
+++ b/test/CMakeLists.txt
@@ -0,0 +1,16 @@
+include(ProcessorCount)
+ProcessorCount(PROCESSORS)
+
+if(NOT PROCESSORS EQUAL 0)
+ set(CTEST_BUILD_FLAGS -j${PROCESSORS})
+ set(ctest_test_args ${ctest_test_args} PARALLEL_LEVEL ${PROCESSORS})
+endif()
+
+get_target_property(LEDGER_LOCATION ledger LOCATION)
+
+add_custom_target(check COMMAND ${CMAKE_CTEST_COMMAND})
+
+add_subdirectory(unit)
+add_subdirectory(regress)
+
+### CMakeLists.txt ends here