summaryrefslogtreecommitdiff
path: root/tools/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tools/Makefile.am')
-rw-r--r--tools/Makefile.am13
1 files changed, 12 insertions, 1 deletions
diff --git a/tools/Makefile.am b/tools/Makefile.am
index 0dd4962c..ad096896 100644
--- a/tools/Makefile.am
+++ b/tools/Makefile.am
@@ -247,7 +247,8 @@ endif
######################################################################
-TESTS = RegressTests BaselineTests ManualTests ConfirmTests GenerateTests
+TESTS = RegressTests BaselineTests ManualTests ConfirmTests \
+ GenerateTests
if HAVE_CPPUNIT
TESTS += \
@@ -258,6 +259,10 @@ TESTS += \
ReportTests
endif
+if DEBUG
+TESTS += CheckTests
+endif
+
if HAVE_BOOST_PYTHON
TESTS += PyUnitTests
endif
@@ -409,6 +414,12 @@ GenerateTests: $(srcdir)/test/GenerateTests.py
echo "$(PYTHON) $(srcdir)/test/GenerateTests.py -j$(JOBS) $(top_builddir)/ledger$(EXEEXT) $(srcdir) 1 ${1:-20} \"\$$@\"" > $@
chmod 755 $@
+CheckTests_SOURCES = test/CheckTests.py
+
+CheckTests:
+ echo "$(PYTHON) $(srcdir)/test/CheckTests.py $(top_builddir)/ledger$(EXEEXT) $(srcdir) \"\$$@\"" > $@
+ chmod 755 $@
+
FULLCHECK=$(srcdir)/test/fullcheck.sh
if HAVE_CPPUNIT