summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorjgravelle-google <jgravelle@google.com>2016-09-09 10:41:00 -0700
committerGitHub <noreply@github.com>2016-09-09 10:41:00 -0700
commitac078dcb1c677f83527693536cb1c06157095447 (patch)
tree0e007d41a98322bbbf28b3a270558d98692a7e1a /CMakeLists.txt
parent87f65f1623983bfc516ff4b222a3bb2537971837 (diff)
downloadbinaryen-ac078dcb1c677f83527693536cb1c06157095447.tar.gz
binaryen-ac078dcb1c677f83527693536cb1c06157095447.tar.bz2
binaryen-ac078dcb1c677f83527693536cb1c06157095447.zip
Add flag to s2wasm to export __growWasmMemory function (#696)
* Add a flag to s2wasm to export grow_memory Binaryen's wasm.js-post.js calls back in to wasm in order to grow the linear memory, via a function that asm2wasm exports called __growWasmMemory. This changes exposes that method through s2wasm when invoked with a flag. * Move AsmConstWalker from wasm-linker to wasm-emscripten * Add test for memory growth in s2wasm * Move makeDynCallThunks into wasm-emscripten module * Move mutation in getTableSegment into a separate method * Move emscripten metadata generation into wasm-emscripten Also make AsmConstWalker internal to the wasm-emscripten module, as it's only used for the metadata pass.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 38b2df763..0d7b27452 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -133,6 +133,7 @@ INSTALL(TARGETS wasm-opt DESTINATION bin)
SET(asm2wasm_SOURCES
src/tools/asm2wasm.cpp
+ src/wasm-emscripten.cpp
src/wasm.cpp
)
ADD_EXECUTABLE(asm2wasm
@@ -144,6 +145,7 @@ INSTALL(TARGETS asm2wasm DESTINATION bin)
SET(s2wasm_SOURCES
src/tools/s2wasm.cpp
+ src/wasm-emscripten.cpp
src/wasm-linker.cpp
src/wasm.cpp
)