summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Schuff <dschuff@chromium.org>2021-10-18 16:57:12 -0700
committerGitHub <noreply@github.com>2021-10-18 23:57:12 +0000
commitbe02d3f0f2689475f31c4523010eed58f39d27cb (patch)
treee62d8f8d15547a54c6c3c40a5752c7f08e4379cd /CMakeLists.txt
parentf0a8de302b85441deb8864c9e20c561c934e27b8 (diff)
downloadbinaryen-be02d3f0f2689475f31c4523010eed58f39d27cb.tar.gz
binaryen-be02d3f0f2689475f31c4523010eed58f39d27cb.tar.bz2
binaryen-be02d3f0f2689475f31c4523010eed58f39d27cb.zip
Update to C++17 and use std::optional for getSuperType (#4203)
This sets the C++ standard variable in the build to C++17, and makes use of std::optional (a C++17 library feature) in one place, to test that it's working.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 336f54342..113aeb901 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -6,7 +6,7 @@ include(GNUInstallDirs)
# The C++ standard whose features are required to build Binaryen.
# Keep in sync with scripts/test/shared.py cxx_standard
-set(CXX_STANDARD 14)
+set(CXX_STANDARD 17)
if(NOT CMAKE_BUILD_TYPE)
message(STATUS "No build type selected, default to Release")