summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlon Zakai <azakai@google.com>2023-04-13 09:50:08 -0700
committerGitHub <noreply@github.com>2023-04-13 09:50:08 -0700
commitc72777feeb8ac83fe91cf525ffbfaa3349ace33c (patch)
tree225911c98b7b37a123914c227b7774b088442928 /CMakeLists.txt
parent1034a6be0b411444f4a2e4fb610a655982d30e31 (diff)
downloadbinaryen-c72777feeb8ac83fe91cf525ffbfaa3349ace33c.tar.gz
binaryen-c72777feeb8ac83fe91cf525ffbfaa3349ace33c.tar.bz2
binaryen-c72777feeb8ac83fe91cf525ffbfaa3349ace33c.zip
Remove binaryen.js debug build changes to WASM_BIGINT flag (#5654)
Fixes #5647
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 13 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 10ee9f16d..07ed2f96d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -305,10 +305,21 @@ else()
endif()
if(EMSCRIPTEN)
- if("${CMAKE_BUILD_TYPE}" MATCHES "Debug")
+ # Note: to debug with DWARF you will usually want to enable BIGINT support, as
+ # that helps avoid running Binaryen on the wasm after link. Binaryen's DWARF
+ # rewriting has known limitations, so avoiding it during link is recommended
+ # where possible (like local debugging).
+ #
+ # Note that this is debug info for Binaryen itself, that is, when you are
+ # debugging Binaryen source code. This flag has no impact on what Binaryen
+ # does when run on wasm files.
+ option(ENABLE_BIGINT "Enable wasm BigInt support" OFF)
+ if(ENABLE_BIGINT)
add_link_flag("-sERROR_ON_WASM_CHANGES_AFTER_LINK")
add_link_flag("-sWASM_BIGINT")
- else()
+ endif()
+
+ if("${CMAKE_BUILD_TYPE}" MATCHES "Release")
# link with -O3 for metadce and other powerful optimizations. note that we
# must use add_link_options so that this appears after CMake's default -O2
add_link_options("-O3")