summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKleis Auke Wolthuizen <github@kleisauke.nl>2022-11-21 20:27:20 +0100
committerGitHub <noreply@github.com>2022-11-21 11:27:20 -0800
commitea0c800b90713edef9566feb30ccb6d276beb857 (patch)
treef6dd6bfdb72ab5e634f1443472cc805b4ef24921 /CMakeLists.txt
parent19cb68dd0cfb2070b434ab9a1bd5b5b9d46fe09b (diff)
downloadbinaryen-ea0c800b90713edef9566feb30ccb6d276beb857.tar.gz
binaryen-ea0c800b90713edef9566feb30ccb6d276beb857.tar.bz2
binaryen-ea0c800b90713edef9566feb30ccb6d276beb857.zip
Remove `-sEXPORT_ES6` + Node.js workaround for binaryen.js (#5235)
This workaround is no longer needed after commit emscripten-core/emscripten@ce4c405.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3538a3bc3..c7d6c266d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -413,7 +413,6 @@ if(EMSCRIPTEN)
target_link_libraries(binaryen_wasm "-sEXPORT_ES6")
target_link_libraries(binaryen_wasm "-sEXPORTED_RUNTIME_METHODS=allocateUTF8OnStack")
target_link_libraries(binaryen_wasm "--post-js=${CMAKE_CURRENT_SOURCE_DIR}/src/js/binaryen.js-post.js")
- target_link_libraries(binaryen_wasm "--extern-pre-js=${CMAKE_CURRENT_SOURCE_DIR}/src/js/binaryen.js-extern-pre.js")
target_link_libraries(binaryen_wasm "-msign-ext")
target_link_libraries(binaryen_wasm "-mbulk-memory")
target_link_libraries(binaryen_wasm optimized "--closure=1")
@@ -455,8 +454,6 @@ if(EMSCRIPTEN)
# js_of_ocaml needs a specified variable with special comment to provide the library to consumers
if(JS_OF_OCAML)
target_link_libraries(binaryen_js "--extern-pre-js=${CMAKE_CURRENT_SOURCE_DIR}/src/js/binaryen.jsoo-extern-pre.js")
- else()
- target_link_libraries(binaryen_js "--extern-pre-js=${CMAKE_CURRENT_SOURCE_DIR}/src/js/binaryen.js-extern-pre.js")
endif()
target_link_libraries(binaryen_js optimized "--closure=1")
# Currently, js_of_ocaml can only process ES5 code