summaryrefslogtreecommitdiff
path: root/src/analysis/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Lively <tlively@google.com>2023-10-20 21:14:20 +0200
committerGitHub <noreply@github.com>2023-10-20 21:14:20 +0200
commitb83d8679a7641312f09380e1cef0e56ceb341d18 (patch)
treeab7bbfc9b98a50e4cbf5517d5a4dbec9bcea00d0 /src/analysis/CMakeLists.txt
parentbe6a3393c36ccc1a0cb0d79b116cbe48e169f93b (diff)
downloadbinaryen-b83d8679a7641312f09380e1cef0e56ceb341d18.tar.gz
binaryen-b83d8679a7641312f09380e1cef0e56ceb341d18.tar.bz2
binaryen-b83d8679a7641312f09380e1cef0e56ceb341d18.zip
[analysis][NFC] Move powerset lattices to their own header (#6028)
Move the powerset lattices out of lattice.h, which now only contains the Lattice concept, to their own dedicated header in a new analysis/lattices directory.
Diffstat (limited to 'src/analysis/CMakeLists.txt')
-rw-r--r--src/analysis/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/analysis/CMakeLists.txt b/src/analysis/CMakeLists.txt
index 2fc4be305..7895e5af8 100644
--- a/src/analysis/CMakeLists.txt
+++ b/src/analysis/CMakeLists.txt
@@ -1,4 +1,4 @@
-file(GLOB analysis_HEADERS *.h)
+file(GLOB analysis_HEADERS *.h lattices/*.h)
set(analysis_SOURCES
cfg.cpp
sign-lattice.cpp