summaryrefslogtreecommitdiff
path: root/src/passes/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2024-12-04 14:49:00 -0800
committerGitHub <noreply@github.com>2024-12-04 22:49:00 +0000
commit68963739e56258057a7f0618e0375dd60ae4e124 (patch)
treef503d42d7c201536b3a77b951d6c813d636db728 /src/passes/CMakeLists.txt
parent47f9a78e5d423638a3dceeed2cb6449766f6f75e (diff)
downloadbinaryen-68963739e56258057a7f0618e0375dd60ae4e124.tar.gz
binaryen-68963739e56258057a7f0618e0375dd60ae4e124.tar.bz2
binaryen-68963739e56258057a7f0618e0375dd60ae4e124.zip
Remove separate Table64Lowering pass (#7131)
This pass is now just part of Memory64Lowering. Once this lands we can remove the `--table64-lowering` flag from emscripten. Because I've used an alias here there will be some interim period where emscripten will run this pass twice since it passed both flags. However, this will only be temporary and that second run will be a no-op since the first one will remove the feature.
Diffstat (limited to 'src/passes/CMakeLists.txt')
-rw-r--r--src/passes/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/passes/CMakeLists.txt b/src/passes/CMakeLists.txt
index 6b78e487d..61c1b2f46 100644
--- a/src/passes/CMakeLists.txt
+++ b/src/passes/CMakeLists.txt
@@ -112,7 +112,6 @@ set(passes_SOURCES
ReorderGlobals.cpp
ReorderLocals.cpp
ReReloop.cpp
- Table64Lowering.cpp
TrapMode.cpp
TypeGeneralizing.cpp
TypeRefining.cpp