summaryrefslogtreecommitdiff
path: root/src/support/CMakeLists.txt
diff options
context:
space:
mode:
authorSam Clegg <sbc@chromium.org>2019-12-04 02:19:51 -0600
committerGitHub <noreply@github.com>2019-12-04 02:19:51 -0600
commitf346478e1eb510d61c603eb6533d2c01f413e47a (patch)
treebbc85b45d2649c16ce2d228330235a9a59aae6c6 /src/support/CMakeLists.txt
parent9cbe295d20dd8bf625e16f26953cb19d35c6daee (diff)
downloadbinaryen-f346478e1eb510d61c603eb6533d2c01f413e47a.tar.gz
binaryen-f346478e1eb510d61c603eb6533d2c01f413e47a.tar.bz2
binaryen-f346478e1eb510d61c603eb6533d2c01f413e47a.zip
Add BYN_DEBUG/BYN_TRACE macros similar to LLVM's debug system (#2496)
This allows for debug trace message to be split my channel. So you can pass `--debug` to simply debug everything, or `--debug=opt` to only debug wasm-opt. This change is the initial introduction but as a followup I hope to convert all tracing over to this new system so we can more easily control the debug output.
Diffstat (limited to 'src/support/CMakeLists.txt')
-rw-r--r--src/support/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/support/CMakeLists.txt b/src/support/CMakeLists.txt
index c8d7632e4..73025d063 100644
--- a/src/support/CMakeLists.txt
+++ b/src/support/CMakeLists.txt
@@ -3,6 +3,7 @@ SET(support_SOURCES
bits.cpp
colors.cpp
command-line.cpp
+ debug.cpp
file.cpp
path.cpp
safe_integer.cpp