summaryrefslogtreecommitdiff
path: root/src/wasm/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Lively <tlively@google.com>2024-12-03 11:20:36 -0800
committerGitHub <noreply@github.com>2024-12-03 11:20:36 -0800
commit87f9dac127b387715d8d96ac7ec8fd469d8c2dab (patch)
treeaa1aec906bf6adc3ea3d93c56616d393850e2249 /src/wasm/CMakeLists.txt
parentf331120e4b942a795d4a6b6d0d5a3d781c1e6a4c (diff)
downloadbinaryen-87f9dac127b387715d8d96ac7ec8fd469d8c2dab.tar.gz
binaryen-87f9dac127b387715d8d96ac7ec8fd469d8c2dab.tar.bz2
binaryen-87f9dac127b387715d8d96ac7ec8fd469d8c2dab.zip
[NFC] Encapsulate source map reader state (#7132)
Move all state relevant to reading source maps out of WasmBinaryReader and into a new utility, SourceMapReader. This is a prerequisite for parallelizing the parsing of function bodies, since the source map reader state is different at the beginning of each function. Also take the opportunity to simplify the way we read source maps, for example by deferring the reading of anything but the position of a debug location until it will be used and by using `std::optional` instead of singleton `std::set`s to store function prologue and epilogue debug locations.
Diffstat (limited to 'src/wasm/CMakeLists.txt')
-rw-r--r--src/wasm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/wasm/CMakeLists.txt b/src/wasm/CMakeLists.txt
index 7a7b26ead..64c88c997 100644
--- a/src/wasm/CMakeLists.txt
+++ b/src/wasm/CMakeLists.txt
@@ -2,6 +2,7 @@ file(GLOB wasm_HEADERS ../*.h)
set(wasm_SOURCES
literal.cpp
parsing.cpp
+ source-map.cpp
wasm.cpp
wasm-binary.cpp
wasm-debug.cpp