summaryrefslogtreecommitdiff
path: root/test/gtest/CMakeLists.txt
diff options
context:
space:
mode:
authorThomas Lively <tlively@google.com>2024-08-01 15:08:25 -0400
committerGitHub <noreply@github.com>2024-08-01 12:08:25 -0700
commit2a7c0931edf681076e678a0e8092e170333c6e86 (patch)
treeaf60ec405b6d6d2a38b1b05466120cebcde45249 /test/gtest/CMakeLists.txt
parent705c28d3a33d606c8c938d079dbf82de7e7a6b7d (diff)
downloadbinaryen-2a7c0931edf681076e678a0e8092e170333c6e86.tar.gz
binaryen-2a7c0931edf681076e678a0e8092e170333c6e86.tar.bz2
binaryen-2a7c0931edf681076e678a0e8092e170333c6e86.zip
Add a disjoint sets (union-find) utility (#6797)
This will be used in an upcoming type optimization pass and may be generally useful.
Diffstat (limited to 'test/gtest/CMakeLists.txt')
-rw-r--r--test/gtest/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/test/gtest/CMakeLists.txt b/test/gtest/CMakeLists.txt
index 4604eea77..538ec1cdc 100644
--- a/test/gtest/CMakeLists.txt
+++ b/test/gtest/CMakeLists.txt
@@ -4,6 +4,7 @@ include_directories(../../src/wasm)
set(unittest_SOURCES
cfg.cpp
dfa_minimization.cpp
+ disjoint_sets.cpp
json.cpp
lattices.cpp
possible-contents.cpp