summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b9120d557..f1ff8fbbe 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -137,7 +137,7 @@ ENDFOREACH()
option(BYN_ENABLE_LTO "Build with LTO" Off)
if(BYN_ENABLE_LTO)
- if(NOT CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ if(NOT CMAKE_CXX_COMPILER_ID MATCHES "Clang")
message(FATAL_ERROR "ThinLTO is only supported by clang")
endif()
if(NOT APPLE)