summaryrefslogtreecommitdiff
path: root/src/support/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/support/CMakeLists.txt')
-rw-r--r--src/support/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/support/CMakeLists.txt b/src/support/CMakeLists.txt
index b3373d076..c8d7632e4 100644
--- a/src/support/CMakeLists.txt
+++ b/src/support/CMakeLists.txt
@@ -8,5 +8,4 @@ SET(support_SOURCES
safe_integer.cpp
threads.cpp
)
-ADD_LIBRARY(support STATIC ${support_SOURCES})
-TARGET_LINK_LIBRARIES(support ${CMAKE_THREAD_LIBS_INIT})
+ADD_LIBRARY(support OBJECT ${support_SOURCES})