summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-07-16 07:47:17 +0100
committerGitHub <noreply@github.com>2023-07-16 07:47:17 +0100
commit104f89df31298f2d7b80b359e97dfee7433d52ff (patch)
treebd4cb65c0398fa0314998391cb42bf551fe55a5d /Cargo.toml
parent3fb1c4ea96d2a7adac2234fb6c3423581b3d39d5 (diff)
downloadcandle-104f89df31298f2d7b80b359e97dfee7433d52ff.tar.gz
candle-104f89df31298f2d7b80b359e97dfee7433d52ff.tar.bz2
candle-104f89df31298f2d7b80b359e97dfee7433d52ff.zip
Centralize the dependency versions and inherit them. (#177)
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml32
1 files changed, 32 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 6337940a..d167d1a7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,6 +12,38 @@ exclude = [
"candle-kernels",
]
+[workspace.dependencies]
+anyhow = { version = "1", features = ["backtrace"] }
+byteorder = "1.4.3"
+clap = { version = "4.2.4", features = ["derive"] }
+# Re-enable this once 0.9.13 as been released as it would include the cublas-f16 changes
+# cudarc = { version = "0.9.13", optional = true, features = ["f16"] }
+cudarc = { git = "https://github.com/LaurentMazare/cudarc.git", branch = "cublas-bf16", features = ["f16"] }
+futures = "0.3.28"
+# TODO: Switch back to the official gemm implementation once something similar to
+# https://github.com/sarah-ek/gemm/pull/8 is available.
+gemm = { git = "https://github.com/LaurentMazare/gemm.git", branch = "f16-vectorize-pack" }
+half = { version = "2.3.1", features = ["num-traits"] }
+indicatif = "0.17.5"
+intel-mkl-src = { version = "0.8.1", features = ["mkl-dynamic-lp64-iomp"] }
+libc = { version = "0.2.147" }
+log = "0.4"
+memmap2 = "0.7.1"
+num_cpus = "1.15.0"
+num-traits = "0.2.15"
+rand = "0.8.5"
+reqwest = "0.11.18"
+safetensors = "0.3.1"
+serde = { version = "1.0.166", features = ["derive"] }
+serde_json = "1.0.99"
+sha256 = "1.1.4"
+thiserror = "1"
+tokenizers = { version = "0.13.3", default-features = false, features = ["onig"] }
+tokio = "1.28.2"
+tokio-test = "0.4.2"
+wav = "1.0.0"
+zip = { version = "0.6.6", default-features = false }
+
[profile.release-with-debug]
inherits = "release"
debug = true