summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2024-03-21 10:56:41 +0100
committerGitHub <noreply@github.com>2024-03-21 10:56:41 +0100
commit18036c6ccbd216e0397fa6469bb50a8b8ea47892 (patch)
tree865a514cb8f2b811f6f5193978933dc7e568c2fc /Cargo.toml
parent0fddec762e3c17c56be5b6356478b9565dd628bb (diff)
downloadcandle-18036c6ccbd216e0397fa6469bb50a8b8ea47892.tar.gz
candle-18036c6ccbd216e0397fa6469bb50a8b8ea47892.tar.bz2
candle-18036c6ccbd216e0397fa6469bb50a8b8ea47892.zip
Update the image crate + use the re-exported version. (#1893)
* Update the image crate + use the re-exported version. * Update to using ab_glyph.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml6
1 files changed, 3 insertions, 3 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 1a3e1983..1f0067b7 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -28,6 +28,7 @@ categories = ["science"]
license = "MIT OR Apache-2.0"
[workspace.dependencies]
+ab_glyph = "0.2.23"
accelerate-src = { version = "0.3.2" }
anyhow = { version = "1", features = ["backtrace"] }
byteorder = "1.4.3"
@@ -46,8 +47,8 @@ fancy-regex = "0.13.0"
gemm = { version = "0.17.0", features = ["wasm-simd128-enable"] }
hf-hub = "0.3.0"
half = { version = "2.3.1", features = ["num-traits", "use-intrinsics", "rand_distr"] }
-image = { version = "0.24.7", default-features = false, features = ["jpeg", "png"] }
-imageproc = { version = "0.23.0", default-features = false }
+image = { version = "0.25.0", default-features = false, features = ["jpeg", "png"] }
+imageproc = { version = "0.24.0", default-features = false }
intel-mkl-src = { version = "0.8.1", features = ["mkl-static-lp64-iomp"] }
libc = { version = "0.2.147" }
log = "0.4"
@@ -58,7 +59,6 @@ parquet = { version = "50.0.0" }
rand = "0.8.5"
rand_distr = "0.4.3"
rayon = "1.7.0"
-rusttype = { version = "0.9", default-features = false }
safetensors = "0.4.1"
serde = { version = "1.0.171", features = ["derive"] }
serde_plain = "1.0.2"