summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJuarez Bochi <juarez.bochi@grammarly.com>2023-11-09 12:55:09 -0500
committerGitHub <noreply@github.com>2023-11-09 18:55:09 +0100
commit18d30005c577c029dec611a0bdd0260946468cdb (patch)
treea465377a7671832df8dad41f64f10074d9656b44 /Cargo.toml
parent695838432747b9c9460e74cd3f5086642b6897a9 (diff)
downloadcandle-18d30005c577c029dec611a0bdd0260946468cdb.tar.gz
candle-18d30005c577c029dec611a0bdd0260946468cdb.tar.bz2
candle-18d30005c577c029dec611a0bdd0260946468cdb.zip
Add support to UL2 model family (#1300)
* Add support to UL2 model family * Update docs with UL2 * Create ActivationWithOptionalGating to avoid polluting activations * Also refactor quantized t5 * Remove useless conversion * Revert Activation::NewGelu name change * Remove useless return * Apply rustfmt and clippy recommendations * Reuse t5::ActivationWithOptionalGating in quantized version * (cosmetic change) use a match rather than ifs + avoid early returns. --------- Co-authored-by: Laurent <laurent.mazare@gmail.com>
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 78926e4f..a1981993 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -50,6 +50,7 @@ rayon = "1.7.0"
rusttype = { version = "0.9", default-features = false }
safetensors = "0.3.1"
serde = { version = "1.0.171", features = ["derive"] }
+serde_plain = "1.0.2"
serde_json = "1.0.99"
thiserror = "1"
tokenizers = { version = "0.13.4", default-features = false }