summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-08-15 09:50:38 +0100
committerGitHub <noreply@github.com>2023-08-15 09:50:38 +0100
commit495e0b758035039e902819f3ed059725d0593be1 (patch)
tree04cf38d2284ed1d0a1238d94e25253e7e3676f3a /Cargo.toml
parent90374097dc99b14dfc935318a18c21fc5909291f (diff)
downloadcandle-495e0b758035039e902819f3ed059725d0593be1.tar.gz
candle-495e0b758035039e902819f3ed059725d0593be1.tar.bz2
candle-495e0b758035039e902819f3ed059725d0593be1.zip
Simd support (#448)
* Import the simd intrinsics in candle-core. * simd version of reduce-sum. * Bugfix. * Fix some clippy lints.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml3
1 files changed, 1 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index cef5c011..2c11b05e 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,9 +31,8 @@ clap = { version = "4.2.4", features = ["derive"] }
cudarc = { version = "0.9.14", features = ["f16"] }
# TODO: Switch back to the official gemm implementation once it has caught up.
gemm = { version = "0.15.6", package = "candle-gemm" }
-ggblas = "0.1.2"
hf-hub = "0.2.0"
-half = { version = "2.3.1", features = ["num-traits", "rand_distr"] }
+half = { version = "2.3.1", features = ["num-traits", "use-intrinsics", "rand_distr"] }
image = { version = "0.24.7", default-features = false, features = ["jpeg", "png"] }
intel-mkl-src = { version = "0.8.1", features = ["mkl-static-lp64-iomp"] }
libc = { version = "0.2.147" }