diff options
author | Nicolas Patry <patry.nicolas@protonmail.com> | 2023-07-28 08:06:13 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-07-28 08:06:13 +0100 |
commit | 4f260ef0257951429274334ed2cc7d775a95593f (patch) | |
tree | e681b5627769fb75c60af83c33580cd5d807fbf4 /Cargo.toml | |
parent | 0b97987b2113b4ccbacee942b9de746ded035feb (diff) | |
parent | 8435a99edd6f5aa7bc86d0ffdaf23e322a93f626 (diff) | |
download | candle-4f260ef0257951429274334ed2cc7d775a95593f.tar.gz candle-4f260ef0257951429274334ed2cc7d775a95593f.tar.bz2 candle-4f260ef0257951429274334ed2cc7d775a95593f.zip |
Merge pull request #216 from LaurentMazare/llama_multiprocess2
TP sharding v2
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -19,8 +19,10 @@ byteorder = "1.4.3" clap = { version = "4.2.4", features = ["derive"] } # Re-enable this once 0.9.13 as been released as it would include the cublas-f16 changes # cudarc = { version = "0.9.13", optional = true, features = ["f16"] } -cudarc = { git = "https://github.com/LaurentMazare/cudarc.git", branch = "cublas-bf16", features = ["f16"] } -# TODO: Switch back to the official gemm implementation if we manage to upstream the changes. +cudarc = { git = "https://github.com/coreylowman/cudarc.git", features = ["f16", "nccl"] } +# TODO: Switch back to the official gemm implementation once the following are available. +# https://github.com/sarah-ek/gemm/pull/8. +# https://github.com/sarah-ek/gemm/pull/9. gemm = { git = "https://github.com/LaurentMazare/gemm.git" } hf-hub = "0.2.0" half = { version = "2.3.1", features = ["num-traits", "rand_distr"] } |