summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorNicolas Patry <patry.nicolas@protonmail.com>2023-12-20 09:54:19 +0100
committerNicolas Patry <patry.nicolas@protonmail.com>2023-12-20 09:54:19 +0100
commit9b5e4843a63180a2803b1e836b4ca90f14281d03 (patch)
tree32dc8468d9201cf079d437f96ad5cdadb2dddb42 /Cargo.toml
parent03641293eeb1dd0ff3d5a93e85c7f9eb289704e4 (diff)
downloadcandle-9b5e4843a63180a2803b1e836b4ca90f14281d03.tar.gz
candle-9b5e4843a63180a2803b1e836b4ca90f14281d03.tar.bz2
candle-9b5e4843a63180a2803b1e836b4ca90f14281d03.zip
Optimizing decode matmul (Phi at 28tok/s on M3).
Adding some benchmark in order to help checking out matmul performance.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 7c2e3a7d..9fda5fba 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -32,6 +32,7 @@ accelerate-src = { version = "0.3.2" }
anyhow = { version = "1", features = ["backtrace"] }
byteorder = "1.4.3"
clap = { version = "4.2.4", features = ["derive"] }
+criterion = { version = "0.5.1", default-features=false }
cudarc = { version = "0.9.14", features = ["f16"] }
gemm = { version = "0.16.6", features = ["wasm-simd128-enable"] }
hf-hub = "0.3.0"