summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-08-10 16:23:52 +0200
committerGitHub <noreply@github.com>2023-08-10 15:23:52 +0100
commitc8039579a5886f1df55a961b98fef3185a560b65 (patch)
tree27297e8dc60e1e585c88007ae17f1bb45a761715 /Cargo.toml
parent0b0fa56978b9fe722250d52c87cf39f9d8b2acdb (diff)
downloadcandle-c8039579a5886f1df55a961b98fef3185a560b65.tar.gz
candle-c8039579a5886f1df55a961b98fef3185a560b65.tar.bz2
candle-c8039579a5886f1df55a961b98fef3185a560b65.zip
Conv1d optimize (#392)
* Reorder the conv1d loops in the cpu backend. * Optimize the 1d convolution. * Conv1D optimize. * Fix some clippy lints.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 850b13ef..c0d87680 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -31,6 +31,7 @@ clap = { version = "4.2.4", features = ["derive"] }
cudarc = { version = "0.9.13", features = ["f16"] }
# TODO: Switch back to the official gemm implementation once it has caught up.
gemm = { version = "0.15.6", package = "candle-gemm" }
+ggblas = "0.1.2"
hf-hub = "0.2.0"
half = { version = "2.3.1", features = ["num-traits", "rand_distr"] }
image = { version = "0.24.7", default-features = false, features = ["jpeg", "png"] }