summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorLaurent Mazare <laurent.mazare@gmail.com>2023-09-23 15:43:11 +0100
committerGitHub <noreply@github.com>2023-09-23 15:43:11 +0100
commitccf352f3d1dfa8bd7531ef1f6caa198fc85cb663 (patch)
treedd7974ac607858461bec2106a020d3cd38419352 /Cargo.toml
parent402d207f0f5f71229f0e24272d0f7b9e4c036573 (diff)
downloadcandle-ccf352f3d1dfa8bd7531ef1f6caa198fc85cb663.tar.gz
candle-ccf352f3d1dfa8bd7531ef1f6caa198fc85cb663.tar.bz2
candle-ccf352f3d1dfa8bd7531ef1f6caa198fc85cb663.zip
Use yoke to provide a self-referential container for mmaped safetenso… (#939)
* Use yoke to provide a self-referential container for mmaped safetensor files. * Add the new self-owned type for safetensor files without removing the previous version. * Add routing. * Add an initializer for the case of multiple files.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml5
1 files changed, 3 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 5ae64523..6db2a326 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -41,9 +41,10 @@ imageproc = { version = "0.23.0", default-features = false }
intel-mkl-src = { version = "0.8.1", features = ["mkl-static-lp64-iomp"] }
libc = { version = "0.2.147" }
log = "0.4"
-memmap2 = "0.7.1"
+memmap2 = { version = "0.7.1", features = ["stable_deref_trait"] }
num_cpus = "1.15.0"
num-traits = "0.2.15"
+parquet = { version = "45.0.0" }
rand = "0.8.5"
rand_distr = "0.4.3"
rayon = "1.7.0"
@@ -57,8 +58,8 @@ tracing = "0.1.37"
tracing-chrome = "0.7.1"
tracing-subscriber = "0.3.7"
wav = "1.0.0"
+yoke = { version = "0.7.2", features = ["derive"] }
zip = { version = "0.6.6", default-features = false }
-parquet = { version = "45.0.0" }
[profile.release-with-debug]
inherits = "release"